sdk v17 breaks admob: Error inflating class

Oh no, when will this end? Been trying to upgrade my app now for 4 hours… and still not there…

Latest error is:  Error inflating class

This is due to sdk v17 – you need to copy the admobs into the /libs folder of your project.